Newbie question - Java version

I've been quietly following JNode for quite some time now and I must say, the work is impressive. I was originally looking for an easy to use Java system and came across JavaPC, KaffePC and Waba for DOS. All of these stopped development a long time ago. JNode is their replacement, and a mighty good one at that. (My interest is purely personal and semi-technical.)

I haven't been able to find in the documentation, what version of Java is supported by JNode. How is each Java version (1.3, 1.4, 1.5) implemented and what features are included/excluded?


java 1.4 I think as ClassPath

There is only one version of JNode (not specific to jdk version).

As you may have seen, JNode use the GNU Classpath project : the last time I went to there web, I saw that they are currently implementing something compatible with JDK 1.4.