(V0.2.5)build-error[class file has wrong version 50.0, should be 49.0]

when i build jnode(v0.2.5) with x86_64
the following error message is given:

class file has wrong version 50.0, should be 49.0

what is the problem ?

Here is all the messages:

Buildfile: D:\jnode\src\all\build.xml
Overriding previous definition of reference to eclipse.ant.targetVector
[jnode.compile] Compiling 14050 source files to D:\jnode\src\core\build\classes
[jnode.compile] D:\jnode\src\core\src\test\org\jnode\test\mauve\MauveTestCommand.java:24: cannot access gnu.testlet.ResourceNotFoundException
[jnode.compile] bad class file: D:\jnode\src\core\lib\mauve.jar(gnu/testlet/ResourceNotFoundException.class)
[jnode.compile] class file has wrong version 50.0, should be 49.0
[jnode.compile] Please remove or make sure it appears in the correct subdirectory of the classpath.
[jnode.compile] import gnu.testlet.ResourceNotFoundException;
[jnode.compile] ^
[jnode.compile] Note: Some input files use or override a deprecated API.
[jnode.compile] Note: Recompile with -Xlint:deprecation for details.
[jnode.compile] 1 error

D:\jnode\src\all\build.xml:167: The following error occurred while executing this line:
D:\jnode\src\all\lib\jnode.xml:65: The following error occurred while executing this line:
D:\jnode\src\core\build.xml:116: Compile failed; see the compiler error output for details.

i need the soln for the error


i am running the same version of java in client as well as server machine but it cannot able to access the serverInteface class file.help me???????

Please be more specific

The problem is caused by using Java bytecode files that were compiled using different versions of Java. This includes third party JAR files.

If you want more help, please provide a more detailed description of what you are trying to do, how you compiled the code you are trying to run, and what the errors are.

thanks for ur info


i had problem in my jpad due to client-server connection..thank for this information

You appear to be using 2 different Java compilers

I suspect that you are mixing code compiled with different versions of Java. Class file version 50.0 is used by Java 6.0, and 49.0 is used by Java 5.0.

Try doing a "build clean" to get rid of all existing class files, followed by a regular build.

JNode is being developed using Java 6.0 only. Last time I tried, it didn't build using Java 5.0 (aka 1.5). (It is a problem with the program that builds the JNode boot image.)

I got it

Thank you.
I got it. I changed the jdk to 1.6 and got it built.